Sample Router Configurations

These are sample router configurations for customers who are using the dedicated port option. Add these to your on-premises router to establish a BGP session with other Cloud Router connections.

Cisco IOS

interface GigabitEthernet 0/1  
 description "Connection to PacketFabric Port"  
 no ip address  
!  
interface GigabitEthernet 0/1.<VLAN_ID>    
 description "PacketFabric Cloud Router EVC"  
 encapsulation dot1q <VLAN_ID>  
 ip address <Customer_IP_Address_and_Mask>  
!  
! PacketFabric recommends setting a route policy for outbound routes.  
ip prefix-list to_PacketFabric seq 5 permit <Customer_Subnet_and_Mask>  
!  
route-map PacketFabric_OUT permit 10  
 match ip address prefix-list to_PacketFabric  
!  
route bgp <Customer_ASN>  
 neighbor <PacketFabric_Cloud_Router_IP> description "PacketFabric"   
 neighbor <PacketFabric_Cloud_Router_IP> remote-as <Cloud_Router_ASN>  
 neighbor <PacketFabric_Cloud_Router_IP> route-map PacketFabric_OUT out  
 ! Soft-Reconfiguration is supported  
 neighbor <PacketFabric_Cloud_Router_IP> soft-reconfiguration inbound  
 ! Every specific network must be explicitly listed  
 network <Customer_Subnet_1>  
 network <Customer_Subnet_2>  
!  

Cisco IOS-XR

   
interface GigabitEthernet 0/0/0/1  
  description "Connection to PacketFabric Port"  
!  
interface GigabitEthernet 0/0/0/1.<VLAN_ID>  
 description "PacketFabric Cloud Router EVC"  
 encapsulation dot1q <VLAN_ID>  
 ip address <Customer_IP_Address_and_Mask>   
!  
prefix_set to_PacketFabric  
 <Customer_Subnet_and_Mask>  
 <Customer_Subnet_and_Mask>  
end-set  
!  
route-policy PacketFabric_OUT  
 if destination in to_PacketFabric then  
  pass  
 else   
  drop  
end-policy  
!  
route-policy PacketFabric_IN  
 pass  
end-policy  
!  
route bgp <Customer_ASN>  
 address-family ipv4 unicast  
  neighbor <PacketFabric_Cloud_Router_IP> description "PacketFabric"  
  neighbor <PacketFabric_Cloud_Router_IP> remote-as <Cloud_Router_ASN>  
  ! Soft-Reconfiguration is supported  
  neighbor <PacketFabric_Cloud_Router_IP> soft-reconfiguration inbound always  
  route-policy PacketFabric_OUT out  
  route-policy PacketFabric_IN in  
 !
!

Junos

set interfaces ge-0/1/0 vlan-tagging
set interfaces ge-0/1/0 unit <VLAN_ID> description Connection to PacketFabric Port
set interfaces ge-0/1/0 unit <VLAN_ID> vlan-id <VLAN_ID> family inet address <Customer_IP_Address_and_Mask>

set policy-options prefix-list PacketFabric_OUT <Customer_Subnet_and_Mask>

set policy-options policy-statement ALLOW-PacketFabric_OUT term PACKETFABRIC from protocol bgp set policy-options policy-statement ALLOW-PacketFabric_OUT term PACKETFABRIC from prefix-list-filter PacketFabric_OUT orlonger set policy-options policy-statement ALLOW-PacketFabric_OUT term PACKETFABRIC then accept set policy-options policy-statement ALLOW-PacketFabric_OUT then reject

set protocols bgp group packetfabric-cr type external set protocols bgp group packetfabric-cr neighbor <PacketFabric_Cloud_Router_IP> peer-as <Cloud_Router_ASN> set protocols bgp group packetfabric-cr neighbor <PacketFabric_Cloud_Router_IP> export PacketFabric_OUT